Pagina 2 di 2 PrimaPrima 12
Risultati da 11 a 13 di 13
  1. #11
    myMeteoNetwork Team L'avatar di Orso Polare
    Data Registrazione
    18/09/08
    Località
    Roma
    Età
    66
    Messaggi
    4,248
    Menzionato
    5 Post(s)

    Predefinito Re: Esportazione dati LaCrosse stile Davis?

    Citazione Originariamente Scritto da The man in the plains Visualizza Messaggio
    Mi autoquoto solo per dire che ora alcuni valori non li vede proprio mentre altri si.
    Ad esempio la temperatura min e max, il rain rate max, la media vento. Mah!
    Non vorrei che con i vari copia ed incolla tra editor diversi, qualche cosa sia andata per storto....
    Come avrai visto dal Dump che avevo allegato al post, a me segnava giusto a parte alcune grandezze che il tuo codice da me usato non ha trovato alcuni dati visto che non avevo GW in uso reale ma senza la stazione collegata ad esso.
    Io proverei a tornare.. all'inizio.... con il tuo codice che avevi allegato al tuo post...
    Una volta appurato che seguitano ad andare male le uniche due cose che in origine non andavano per cui.. pressione e unità di misura dei gradi sul vento.... farei sul codice che stai usando una modifica per volta delle due interessate al problema.

    Io ho modificato aggiungendo alle due righe queste modifiche:

    $Current[relative_pressure] $Unit[Pressure]

    ed anche:

    $Stats[Day,TrueMean,wind_speed,f1] $Unit[Speed] da $Current[wind_direction,f1]


  2. #12
    Burrasca L'avatar di The man in the plains
    Data Registrazione
    11/02/06
    Località
    Piacenza
    Età
    24
    Messaggi
    5,762
    Menzionato
    0 Post(s)

    Predefinito Re: Esportazione dati LaCrosse stile Davis?

    Citazione Originariamente Scritto da Orso Polare Visualizza Messaggio
    Non vorrei che con i vari copia ed incolla tra editor diversi, qualche cosa sia andata per storto....
    Come avrai visto dal Dump che avevo allegato al post, a me segnava giusto a parte alcune grandezze che il tuo codice da me usato non ha trovato alcuni dati visto che non avevo GW in uso reale ma senza la stazione collegata ad esso.
    Io proverei a tornare.. all'inizio.... con il tuo codice che avevi allegato al tuo post...
    Una volta appurato che seguitano ad andare male le uniche due cose che in origine non andavano per cui.. pressione e unità di misura dei gradi sul vento.... farei sul codice che stai usando una modifica per volta delle due interessate al problema.

    Io ho modificato aggiungendo alle due righe queste modifiche:

    $Current[relative_pressure] $Unit[Pressure]

    ed anche:

    $Stats[Day,TrueMean,wind_speed,f1] $Unit[Speed] da $Current[wind_direction,f1]

    Ho fatto una cosa ancor più semplice: ho rifatto da capo due righe di codice basilari, te le allego:

    Codice HTML:
    <html>
    <head>
    </head>
    <body>
    Data: $CurrentDate[%d/%m/%Y]<br> 
    Ora: $CurrentDate[%H:%M]<br> 
    Temperatura: $Current[outdoor_temperature]<br> 
    Umiditò: $Current[outdoor_humidity]<br>
    Vel. Vento: $Current[wind_speed]<br> 
    Dir. Vento: $Current[wind_direction,f1]<br> 
    Pressione: $Current[relative_pressure]<br> 
    Pioggia Giorno: $Cumul[relative_rainfall]<br> 
    Rain Rate: $Max[rainfall_1h]<br>
    T. Max: $Max[outdoor_temperature]<br> 
    T. Min: $Min[outdoor_temperature]<br> 
    Raffica: $Max[wind_speed,f1]<br>
    WindChill: $Current[wind_chill]<br> 
    Dew Point: $Current[dew_point]<br>
    Pioggia Mese: $Stats[Month,TotalRainfall]<br> 
    Pioggia Anno: $Stats[Year,TotalRainfall]<br> 
    </body>
    </html>
    Due cose non quadrano ugualmente però:

    - il Rain Rate: con quello script viene messo il RR max giornaliero e mi può stare anche bene, ma se volessi mettere quello attuale lo script diventerà $Current[rainfall_1h]...ma LaCrosse non mi sembra che lo calcoli??

    - la Pioggia Mese: come mai segna zero nonostante ne sia caduta una certa quantità? Forse lo script è errato?

    Grazie mille
    Giacomo

  3. #13
    myMeteoNetwork Team L'avatar di Orso Polare
    Data Registrazione
    18/09/08
    Località
    Roma
    Età
    66
    Messaggi
    4,248
    Menzionato
    5 Post(s)

    Predefinito Re: Esportazione dati LaCrosse stile Davis?

    Citazione Originariamente Scritto da The man in the plains Visualizza Messaggio
    CUT

    Due cose non quadrano ugualmente però:

    - il Rain Rate: con quello script viene messo il RR max giornaliero e mi può stare anche bene, ma se volessi mettere quello attuale lo script diventerà $Current[rainfall_1h]...ma LaCrosse non mi sembra che lo calcoli??

    - la Pioggia Mese: come mai segna zero nonostante ne sia caduta una certa quantità? Forse lo script è errato?

    Grazie mille
    Giacomo
    Secondo il mio parere se non rispetti la sintassi dei TAGS, alcune grandezze meteo non saranno rappresentate o lo saranno in maniera errata.... e vedo che nel codice non hai messo su nessun TAGS la sua unità di misura accanto al TAGS stesso...

    Per il Rain Rate, non vorrei dire una inesattezza dato che la Ws l'ho tolta da parecchio e non ricordo bene.... ma non è la stazione a calcolarlo ma GW in base alle precipitazioni registrate.....
    Gigi600 che ancora tiene in vita una WS2300, ha dei grafici in cui compare detto parametro per cui......


Segnalibri

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •