Risultati da 1 a 3 di 3
  1. #1
    Vento forte
    Data Registrazione
    18/09/19
    Località
    Catania
    Messaggi
    4,352
    Menzionato
    133 Post(s)

    Angry Oregon Scientific WMR200 non più supportato da WEEWX

    All’inizio del 2020 avevo provato WeeWx con una Oregon Scientific WMR200 su un RaspberryPi ed era andata maluccio, al lancio del programma prendeva solo un dato e si piantava. L’installazione era stata fatta seguendo le istruzioni ed era andata senza problemi.
    Alcuni giorni fa ho provato daccapo con l’ultima versione su un minipc ma sempre con Linux, più precisamente Ubuntu 18.04, stavolta con molti problemi in più. Ma la cosa più strana era che non mi compariva più la WMR200 nel menù di scelta delle console.
    Controllo nell’elenco delle console supportate
    WeeWX: Supported Hardware
    e la WMR200 c’è, come ricordavo.
    ma nell’elenco dei driver da usare a seconda delle stazioni
    weewx: Hardware Guide
    la WMR200 non c’è più. Mi dico, sarà un errore, poco male, scelgo la WMR100 anche perché nel menù mi pare di ricordare che la WMR200 andava con il driver wmr100.
    Ma non funziona nulla.

    Allora mi vado a leggere il file changelog.txt che riporta le novità e i cambiamenti e trovo questo:

    4.3.0 01/04/2020


    The WMR200 driver is no longer supported. An unsupported version can be found

    at GitHub - weewx/weewx-wmr200: Unsupported driver for the Oregon Scientific WMR200. Support for LaCrosse WS23xx and
    Oregon WMR300 will continue.
    Nella pagina del driver su github trovo questo

    This is a driver for the Oregon Scientific WMR200 weather station for the WeeWX weather system. It was originally part of the main WeeWX distribution, but was split off in December 2020 because of continuing support problems. In particular, it is known to get occasional "Resource busy" errors. See WeeWX issue#578.

    The driver is unsupported

    WeeWX V4 and Python 3.x compatible.
    Quindi mi vado a leggere l’issue 578 e fra i tanti commenti trovo questo dell’utente tfilo

    Hello, I see that this issue is closed but is there any working solution ? I used weewx for many years with older raspbian and it worked fine. Today I upgraded to Raspberry PI OS Buster, installed weewx based on python 3 and I got this error. I can reproduce it every boot. First I see in log that weewx is waiting 60 second for mysql to be ready. Than it shows this error and exits. If I start weewx manually, everything is working.
    L’utente descrive gli stessi errori incontrati da me, weewx legge un solo dato e si pianta con gli stessi errori descritti nell’issue su github e che non riporto qui per non far diventare questo post un romanzo. Sembrerebbe che vecchie versioni sia di Weewx che di raspbian non abbiano problemi. Ma quali?


    Leggendo ulteriormente pare che neanche ritornando al Python 2.x il problema si risolva.


    Ma nessun altro ha problemi con Weewx e la WMR200?

    Io ho provato fino adesso Weater Station Data Logger o WSDL su Windows 7 e 10 e funziona nonostante non sia aggiornato da anni ma non ho un equivalente sotto Linux, penso proverò CumulusMX.

  2. #2
    Vento fresco L'avatar di Guglielmo
    Data Registrazione
    22/12/15
    Località
    Roma Prenestina Cocconi
    Età
    50
    Messaggi
    2,528
    Menzionato
    3 Post(s)

    Predefinito Re: Oregon Scientific WMR200 non più supportato da WEEWX

    Citazione Originariamente Scritto da zoomx Visualizza Messaggio
    All’inizio del 2020 avevo provato WeeWx con una Oregon Scientific WMR200 su un RaspberryPi ed era andata maluccio, al lancio del programma prendeva solo un dato e si piantava. L’installazione era stata fatta seguendo le istruzioni ed era andata senza problemi.
    Alcuni giorni fa ho provato daccapo con l’ultima versione su un minipc ma sempre con Linux, più precisamente Ubuntu 18.04, stavolta con molti problemi in più. Ma la cosa più strana era che non mi compariva più la WMR200 nel menù di scelta delle console.
    Controllo nell’elenco delle console supportate
    WeeWX: Supported Hardware
    e la WMR200 c’è, come ricordavo.
    ma nell’elenco dei driver da usare a seconda delle stazioni
    weewx: Hardware Guide
    la WMR200 non c’è più. Mi dico, sarà un errore, poco male, scelgo la WMR100 anche perché nel menù mi pare di ricordare che la WMR200 andava con il driver wmr100.
    Ma non funziona nulla.

    Allora mi vado a leggere il file changelog.txt che riporta le novità e i cambiamenti e trovo questo:


    Nella pagina del driver su github trovo questo

    Quindi mi vado a leggere l’issue 578 e fra i tanti commenti trovo questo dell’utente tfilo


    L’utente descrive gli stessi errori incontrati da me, weewx legge un solo dato e si pianta con gli stessi errori descritti nell’issue su github e che non riporto qui per non far diventare questo post un romanzo. Sembrerebbe che vecchie versioni sia di Weewx che di raspbian non abbiano problemi. Ma quali?


    Leggendo ulteriormente pare che neanche ritornando al Python 2.x il problema si risolva.


    Ma nessun altro ha problemi con Weewx e la WMR200?

    Io ho provato fino adesso Weater Station Data Logger o WSDL su Windows 7 e 10 e funziona nonostante non sia aggiornato da anni ma non ho un equivalente sotto Linux, penso proverò CumulusMX.
    Io la utilizzo e funziona perfettamente su Cumulus.


    S.S. Lazio 1900

  3. #3
    Vento forte
    Data Registrazione
    18/09/19
    Località
    Catania
    Messaggi
    4,352
    Menzionato
    133 Post(s)

    Predefinito Re: Oregon Scientific WMR200 non più supportato da WEEWX

    Sto usando pure CumulusMX ma con la Ecowitt. Volevo provare WeeWx ma mi ha dato così tanti problemi che volevo mettere su un'altra istanza di CumulusMX.
    Alla fine comunque ci sono riuscito usando il driver che non supportano più, che significa che se ci sono problemi è inutile che chiedo.
    Già una volta si è piantato ma adesso sembra andare.
    Però il fatto che abbiano tolto il supporto ad una console credo abbastanza diffusa senza annunciarlo a caratteri cubitali non mi è piaciuto. Inoltre ancora risulta nell'elenco dell'hardware supportato.
    Questo spiega i fallimenti dei precedenti tentativi su un router modificato e su un raspberrypi.
    Probabilmente le vecchie versioni su python2.x vanno ancora ma il python2.x è ormai a fine vita.

Segnalibri

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •