Risultati da 1 a 9 di 9
  1. #1
    Calma di vento
    Data Registrazione
    17/09/08
    Località
    prov. di AP
    Messaggi
    40
    Menzionato
    1 Post(s)

    MeteoNetwork Problema al database weewx

    Un saluto a tutti,
    da fine 2017 ho una Davis VP2 Plus con datalogger USB collegato ad un raspberry su cui è installato weewx con skin sofaskin con cui invio i dati sul mio dominio web ed a Meteonetwork.
    Oggi stavo facendo alcuni aggiornamenti sul sistema operativo e purtroppo per qualche motivo si sono corrotti alcuni dati, allego un'immagine della stampa del file syslog.Ora in tutti i grafici appare un buco visibile nella seconda immagine: come posso rimediare?
    Ho installato db browser per dare un'occhiata al file weewx.sdb ma non so come riparare il database per far scomparire il buco.Potete darmi qualche suggerimento per risolvere il problema?Grazie.
    Anteprime Allegate Anteprime Allegate Problema al database weewx-errore-database.jpg   Problema al database weewx-errore-database-pressione.jpg  

  2. #2
    Tempesta L'avatar di snow
    Data Registrazione
    26/08/09
    Località
    Termini Imerese (PA)
    Messaggi
    12,228
    Menzionato
    212 Post(s)

    Predefinito Re: Problema al database weewx

    Citazione Originariamente Scritto da automan73 Visualizza Messaggio
    Un saluto a tutti,
    da fine 2017 ho una Davis VP2 Plus con datalogger USB collegato ad un raspberry su cui è installato weewx con skin sofaskin con cui invio i dati sul mio dominio web ed a Meteonetwork.
    Oggi stavo facendo alcuni aggiornamenti sul sistema operativo e purtroppo per qualche motivo si sono corrotti alcuni dati, allego un'immagine della stampa del file syslog.Ora in tutti i grafici appare un buco visibile nella seconda immagine: come posso rimediare?
    Ho installato db browser per dare un'occhiata al file weewx.sdb ma non so come riparare il database per far scomparire il buco.Potete darmi qualche suggerimento per risolvere il problema?Grazie.
    Non riesci a tornare alla versione stabile precedente? @zoomx tu che sei molto abile in quest'ambito, hai qualche suggerimento?

  3. #3
    Calma di vento
    Data Registrazione
    17/09/08
    Località
    prov. di AP
    Messaggi
    40
    Menzionato
    1 Post(s)

    Predefinito Re: Problema al database weewx

    Ci ho provato, ho ripristinato l'immagine della memoria microSD stabile e funzionante dell'anno scorso, ho stoppato il loop di weewx ed ho sostituito il file weewx.sdb con l'ultimo archiviato in automatico ieri notte a mezzanotte: ma poi quando faccio ripartire il loop di weewx, questo giustamente aggiunge i dati mancanti più recenti prelevandoli dal logger e durante questa operazione ad un certo punto compaiono gli errori visibili nella prima foto.
    Spero si possa sistemare in qualche modo...

  4. #4
    Vento fresco
    Data Registrazione
    18/09/19
    Località
    Catania
    Messaggi
    2,379
    Menzionato
    90 Post(s)

    Predefinito Re: Problema al database weewx

    Hai i dati mancanti in qualche formato?

  5. #5
    Calma di vento
    Data Registrazione
    17/09/08
    Località
    prov. di AP
    Messaggi
    40
    Menzionato
    1 Post(s)

    Predefinito Re: Problema al database weewx

    Ciao @zoomx non ho i dati mancanti anche se in realtà i dati non sembrano mancare, mi spiego meglio.
    Guardando l'immagine del file syslog ho notato che:
    1) l'ultimo dei dati "buoni" ed il primo dopo i dati "corrotti" a guardare il numero di indice e data/ora sembrano conseguenti, quindi sembra non mancare nulla.
    2) guardando l'indice e la data/ora dei dati "errati", noto che dati con lo stesso indice, la stessa data/ora e la stessa timezone sono stati scaricati correttamente parecchie righe prima (nell'immagine allegata non si vedono perchè sono precedenti).
    Sembra quasi che nel datalogger siano presenti dei dati "doppione" ma ciò non mi sembra possibile.
    Premetto che sono autodidatta in materia e che potrei dire delle castronerie.



  6. #6
    Vento fresco
    Data Registrazione
    18/09/19
    Località
    Catania
    Messaggi
    2,379
    Menzionato
    90 Post(s)

    Predefinito Re: Problema al database weewx

    Quindi basterebbe cancellare i dati corrotti? Se si basta aprire il database con DB Browser for SQLite, selezionare i dati corrotti e usare Delete Records.
    Ricordati di lavorare con una copia. Credo anche che mentre fai questo lavoro Weewx vada fermato altrimenti aggiorna il database con valori nuovi.
    WeeWX ha anche questa guida
    Cleaning up old 'bad' data . weewx/weewx Wiki . GitHub
    che però va a linea di comando, sebbene con executeSQL puoi eseguire gli stessi comandi eliminando l'echo iniziale e la parte dopo il |

  7. #7
    Calma di vento
    Data Registrazione
    17/09/08
    Località
    prov. di AP
    Messaggi
    40
    Menzionato
    1 Post(s)

    Predefinito Re: Problema al database weewx

    Aggiungo una immagine della stampa del file syslog con evidenziato in rosso il problema che ho cercato di spiegare.

    Problema al database weewx-errore-database-evidence.jpg

    Se non ho capito male suggerisci di lavorare con db browser su una copia del database rigenerato: mi aspettavo di trovare delle righe dati due a due con indici uguali ed immaginavo che dovevo cancellare le righe doppione per sistemare il file di database ma non ho trovato alcuna riga duplicata. Tutti i dati relativi agli indici segnalati come "unable to add a record" sono presenti nel database. Quello che non capisco è come mai il loop di weewx cerca di scaricarli una seconda volta e soprattutto perchè si crea quel buco se i dati sono presenti nel database.
    C'è un comando che posso lanciare da riga di testo per fare una sorta di recovery del database?
    Ultima modifica di automan73; 19/06/2020 alle 12:09

  8. #8
    Vento fresco
    Data Registrazione
    18/09/19
    Località
    Catania
    Messaggi
    2,379
    Menzionato
    90 Post(s)

    Predefinito Re: Problema al database weewx

    Non uso WeeWX ma questo credo sia quello che può fare caso al tuo problema, purtroppo in inglese e a linea di comando<br>weewx: Utilities Guide

  9. #9
    myMeteoNetwork Team L'avatar di Raffaello
    Data Registrazione
    19/05/09
    Località
    Scandriglia(RI)
    Età
    49
    Messaggi
    879
    Menzionato
    94 Post(s)

    Predefinito Re: Problema al database weewx

    Ciao @automan73,
    innanzi tutto fatti una copia del db per evitare di corrompere quello che hai.
    Basta fare cp perchè il DB è tutto in quel file.
    Poi con sqlitebrowser controlla di non avere record con data 00000000. E' probabile che ci sia stato qualche problema con l'orario della raspberry in quel momento.

    La guida sul cleanup del DB postata da @zoomx è OK. Ma non fa miracoli. Se i dati non sono stati scritti, non li hai.
    -------------------------
    Raffaello Di Martino - IZ0QWM
    http://www.kwos.it - https://www.facebook.com/kwos.it

Segnalibri

Permessi di Scrittura

  • Tu non puoi inviare nuove discussioni
  • Tu non puoi inviare risposte
  • Tu non puoi inviare allegati
  • Tu non puoi modificare i tuoi messaggi
  •